Question : I can connect with VPN client but can not ping or connect to any clients on the inside.

I am having difficulty connecting to a computer behind a Cisco ASA 5505.  The setup is as follows:  Static IP address on Bell network using their HS modem in Router Mode.  PPPOE is configured on the modem.  Outside = Static IP Address and inside is set to 192.168.2.1.  A static routing statement is in the modem to be able to connect to the ASA from the Internet.  

I can connect to the ASA successfully with a Cisco VPN Client 5.0.02.0090, in that I receive an ip address and subnet mask (but no gateway).  When i try to ping the PC on the other side it comes back as "Request timed out".  I can not use VNC or net use statements to connect to it either.  I wondered if it might be NAT traversal so i inserted "crypto isakmp nat-traversal 20" but then I could not connect to the ASA anymore.  

Any help would be appreciated.
Code Snippet:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
82:
83:
84:
85:
86:
87:
88:
89:
90:
91:
92:
93:
94:
95:
96:
97:
98:
99:
100:
101:
102:
103:
104:
105:
106:
107:
108:
109:
110:
111:
112:
113:
114:
115:
116:
117:
118:
119:
120:
121:
122:
123:
124:
125:
126:
127:
128:
129:
130:
131:
132:
133:
134:
135:
136:
137:
138:
139:
140:
141:
142:
143:
144:
: Saved
:
ASA Version 7.2(3) 
!
hostname 
domain-name mslk.com
enable password 
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.50.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 192.168.2.10 255.255.255.0 
!
interface Vlan3
 shutdown
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name mslk.com
same-security-traffic permit intra-interface
access-list asdf_splitTunnelAcl standard permit 192.168.50.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip 192.168.50.0 255.255.255.0 192.168.10.0 255.255.255.240 
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip local pool mslkvpn_pool 192.168.10.1-192.168.10.10 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 192.168.2.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.50.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto dynamic-map outside_dyn_map 20 set pfs 
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.50.2-192.168.50.33 inside
dhcpd enable inside
!
 
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
group-policy asdf internal
group-policy asdf attributes
 vpn-tunnel-protocol IPSec 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value asdf_splitTunnelAcl
username admin password 
username admin attributes
 vpn-group-policy asdf
username mschmidt password 
username mschmidt attributes
 vpn-group-policy asdf
tunnel-group asdf type ipsec-ra
tunnel-group asdf general-attributes
 address-pool mslkvpn_pool
 default-group-policy asdf
tunnel-group asdf ipsec-attributes
 pre-shared-key *
prompt hostname context 
Cryptochecksum:5875b777042770bddbc93c4192e4a4eb
: end
asdm image disk0:/asdm-523.bin
no asdm history enable
Open in New Window Select All

Answer : I can connect with VPN client but can not ping or connect to any clients on the inside.

More than likely this is a problem with the DSL modem.  Since it is performing NAT and is not just passing traffic (like in bridge mode), there is the potential for that modem to be blocking/filtering the IPSEC traffic.  Is there an IPSEC pass through option that can be configured on it?

I would say that you may want to consider putting that modem into bridge mode and let the ASA perform the PPPoE negotiation and NAT.  This way, the ASA would receive the public IP address and you would set up your VPN client to connect directly to the ASA...much cleaner and more reliable.
Random Solutions  
 
programming4us programming4us