Question : VPN client to PIX failure

I have a PIX 501 that had VPN client access working.  I am trying to set up a VPN tunnel to a SonicWall.  When I implemented the changes for the tunnel the client no longer connects and gives the error message: "
10     12:20:26.003  02/26/08  Sev=Warning/3      IKE/0xA3000056
Driver says we received a packet with invalid SPI (0), sending INVALID-SPI notify."

It does that ten times and then fails.

This is the original PIX config:
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password yMBhGhjGTdWMalpC encrypted
passwd Jgd4jCZpu71vflyC encrypted
hostname SupaPix
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list inside_outbound_nat0_acl permit ip any 172.17.2.96 255.255.255.224
access-list outside_cryptomap_dyn_20 permit ip any 172.17.2.96 255.255.255.224
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 158.6.2.76 255.255.255.128
ip address inside 172.17.2.65 255.255.255.192
ip audit info action alarm
ip audit attack action alarm
ip local pool SupaPool 172.17.2.105-172.17.2.114
pdm location 65.43.7.144 255.255.255.240 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 158.116.2.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 65.43.7.144 255.255.255.240 outside
http 172.17.2.64 255.255.255.192 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup Supagram address-pool SupaPool
vpngroup Supagram idle-time 1800
vpngroup Supagram password ********
telnet 0.0.0.0 0.0.0.0 outside
telnet 172.17.2.64 255.255.255.192 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 172.17.2.64 255.255.255.192 inside
ssh timeout 10
management-access inside
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:f5cd646e6fb40fdaf1e2d5e1db5e0eea
: end

This is what I added for the VPN tunnel:
isakmp identity address
isakmp key ********** address 65.43.7.158 netmask 255.255.255.255
access-list 101 permit ip 172.17.2.64 255.255.255.192 172.16.19.98 255.255.255.255
crypto ipsec transform-set supaset esp-3des esp-md5-hmac
crypto ipsec security-association lifetime seconds 900
crypto map supamap 10 ipsec-isakmp
crypto map supamap 10 match address 101
crypto map supamap 10 set transform-set supaset
crypto map supamap 10 set peer 65.43.7.158
crypto map supamap interface outside


Not sure what broke the connection.
Another thing to add is that the secure tunnel to the SonicWall does not fully function yet.
The IKE phase one completes but the phase two fails with the following error in the SonicWall log:
2      02/26/2008 13:11:31.496      Warning      VPN IKE      Received notify. NO_PROPOSAL_CHOSEN      158.6.2.76, 500      65.43.7.158, 500            
3      02/26/2008 13:11:31.496      Debug      VPN IKE      RECEIVED<<< ISAKMP OAK INFO (InitCookie:0x7ffd00b6e2b267fa RespCookie:0x543b40047c6eeaa4, MsgID: 0x1EC87312) *(HASH, NOTIFY: NO_PROPOSAL_CHOSEN)      158.6.2.76, 500      65.43.7.158, 500             

Any assistance would be great on either or both issues (since they are probably related).

Answer : VPN client to PIX failure

Somehow the crypto map got unapplied from the outside interface.  Issue this command:

crypto map outside_map interface outside
Random Solutions  
 
programming4us programming4us