Question : ASA5505 IMAP4 Configuration RE:IPHONE

Having issues configuring access for IMAP4 email on one of my locations servers/firewalls for IMAP4 email access.  to be honest i have never had to support imap email access before, everyone has been satisfied with other protocols.  any help would be appriciated.



Thanks,


Dave
Code Snippet:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
82:
83:
84:
85:
86:
87:
88:
89:
90:
91:
92:
93:
94:
95:
96:
97:
98:
99:
100:
101:
102:
103:
104:
105:
106:
107:
108:
109:
110:
111:
112:
113:
114:
115:
116:
117:
118:
119:
120:
121:
122:
123:
124:
125:
126:
127:
128:
129:
130:
131:
132:
133:
134:
135:
136:
137:
138:
139:
140:
141:
142:
143:
144:
145:
146:
147:
148:
149:
150:
151:
152:
153:
154:
155:
156:
157:
158:
159:
160:
161:
162:
163:
164:
165:
166:
167:
168:
169:
170:
171:
172:
173:
174:
175:
176:
177:
178:
179:
180:
181:
182:
183:
184:
185:
186:
187:
188:
189:
190:
191:
192:
193:
194:
195:
196:
197:
198:
199:
200:
201:
Result of the command: "sh runn"
 
: Saved
:
ASA Version 7.2(3) 
!
hostname meme
domain-name ya.ta
enable password helllo encrypted
names
name 192.168.2.5 nono
name 192.168.2.0 nono2
name 192.168.2.16 nono3
name 192.168.2.15 nono4
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.2.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 1.2.3.4 255.255.255.225 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd helllo encrypted
ftp mode passive
clock timezone MST -7
dns server-group DefaultDNS
 domain-name nodomain.no
object-group service imap4 tcp
 port-object eq imap4
access-list outside_access_in extended permit tcp any host 1.2.3.5 eq www 
access-list outside_access_in extended permit tcp any host 1.2.3.5 eq smtp 
access-list outside_access_in extended permit tcp any host 1.2.3.5 eq 3389 
access-list outside_access_in extended permit tcp any host 1.2.3.5 eq 8768 
access-list outside_access_in extended permit udp any host 1.2.3.5 eq 8768 
access-list outside_access_in extended permit udp any host 1.2.3.5 eq 3874 
access-list outside_access_in extended permit tcp any host 1.2.3.5 eq 51234 
access-list outside_access_in extended permit tcp any host 1.2.3.5 eq 14534 
access-list outside_access_in extended permit udp any host 1.2.3.5 eq 8767 
access-list outside_access_in extended permit tcp any host 1.2.3.5 eq 3874 
access-list outside_access_in extended permit tcp any host 1.2.3.5 eq https 
access-list outside_access_in extended permit tcp any any eq 4125 
access-list outside_access_in extended permit tcp any host 1.2.3.5 eq 993 
access-list outside_access_in extended permit tcp any host 1.2.3.5 eq imap4 
access-list inside_outbound_nat0_acl extended permit ip any 192.168.2.48 255.255.255.248 
access-list outside_cryptomap_dyn_20 extended permit ip any 192.168.2.48 255.255.255.248 
access-list nonogroup_splitTunnelAcl standard permit any 
access-list outside_in extended permit tcp any host 1.2.3.5 eq imap4 
access-list in remark rule imap4
pager lines 24
logging enable
logging timestamp
logging trap debugging
logging asdm informational
logging device-id hostname
mtu inside 1500
mtu outside 1500
ip local pool myvpnpool_192.168.2.50-192.168.2.55 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp permit any outside
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 1.2.3.7 nono2 netmask 255.255.255.255 
static (inside,outside) 1.2.3.6 192.168.2.7 netmask 255.255.255.255 
static (inside,outside) 1.2.3.5 nono netmask 255.255.255.255 
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 12.43.19.193 1
timeout xlate 0:05:00
timeout conn 0:00:00 half-closed 0:10:00 udp 0:00:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 0:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
http server enable
http 0.0.0.0 0.0.0.0 outside
http lamain 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
snmp-server enable traps snmp authentication linkup linkdown coldstart
 
LEFT OUT ON PURP
 
 hash md5
 group 2
 lifetime 86400
crypto isakmp policy 40
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
telnet ttttmain 255.255.255.0 inside
telnet 0.0.0.0 0.0.0.0 outside
telnet timeout 5
ssh timeout 5
console timeout 0
management-access inside
l2tp tunnel hello 10
dhcpd dns 2.2.2.2.2.2.2.2.2.2.2
dhcpd auto_config outside
!
dhcpd address 192.168.2.2-192.168.2.129 inside
!
vpnclient server 192.168.2.1
vpnclient mode client-mode
vpnclient vpngroup dddd password ********
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
  inspect http 
!
service-policy global_policy global
group-policy tttgrp internal
group-policy tttgrp attributes
 dns-server value 192.168.2.5
 vpn-tunnel-protocol IPSec 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value nA_splitTunnelAcl
 default-domain value dddr
group-policy lamain internal
group-policy lamian attributes
 vpn-idle-timeout 30
 default-domain value ddd.tv
group-policy you internal
group-policy you attributes
 vpn-idle-timeout 30
 default-domain value dddd.tv
username er password dfdfdfdf encrypted privilege 0
username er attributes
 vpn-group-policy rre
username re password dfdfdfdf encrypted privilege 0
username re attributes
 vpn-group-policy rrre
username dfd password sdfdsddssdfds encrypted privilege 0
username dfdf attributes
 vpn-group-policy rrre
tunnel-group  sdf type ipsec-ra
tunnel-group  sf general-attributes
 address-pool  sadf 
 default-group-policy lamam
tunnel-group  asdf ipsec-attributes
 pre-shared-key *
tunnel-group  sdf type ipsec-ra
tunnel-group sdf general-attributes
 address-pool sdaf  
 default-group-policy Wally
tunnel-group you ipsec-attributes
 pre-shared-key *
tunnel-group sdf type ipsec-ra
tunnel-group sdf general-attributes
 address-pool sdfa
 default-group-policy sdafa
tunnel-group lamain ipsec-attributes
 pre-shared-key *
prompt hostname context 
no compression svc http-comp
Open in New Window Select All

Answer : ASA5505 IMAP4 Configuration RE:IPHONE

If you check your logs do you see IMAP being DENIED by the ASA? It may be using IMAP over SSL (especially if it's iPhone) then it uses TCP port# 993.
Random Solutions  
 
programming4us programming4us